This is an old revision of the document!


SharpWComp Installation

WComp on Windows

Required packages for the installation are listed in the download page. You can find the documentation in the page corresponding to each WComp release. Here are all the versions of WComp which are available on this website. You can find all the details for installing, requirements and documentation for each release.

WComp on Phidget SBC 107x

As on Linux platform, WComp needs Mono to execute C# code. The phidget packages' repository contains Mono, so we will install this in order to use WComp.

In order to install Mono on Phidget SBC 107x, do the following:

  • Update the system installed on your platform. After being loggued as super user (root), you must upgrade it using:
apt-get update; apt-get dist-upgrade
  • Go to the web interface of your platform and go to System / Packages and check Include Full Debian Repository and Save Changes. Then Refresh Available Packages and Upgrade All Packages. Your system is now uptodate.
  • Install the mono environment:
apt-get install mono-runtime mono-gmcs libmono-system-web2.0-cil
  • Enable phidget for .NET environment
apt-get install libphidget21-dev
apt-get install wget unzip
wget http://www.phidgets.com/downloads/libraries/Phidget21-windevel_2.1.8.20121015.zip
unzip Phidget21-windevel_2.1.8.20121015.zip
gacutil -i phidget21-windevel/Phidget21.NET.dll
ln -s /usr/lib/mono/gac/Phidget21.NET/*/* /usr/lib/mono/2.0/Phidget21.NET.dll
  • Unzip SharpWCompContainer where you want, to be able to us it.

WComp on Raspberry Pi

As on Linux platform, WComp needs Mono to execute C# code. Current Raspberry Pi distribustion are compiled for ARM with support for “hard float” which means that float computation are done directly by the processor and not by a soft evaluation.

But for the moment, Mono has a known bug on "hard float" version. So we need to use a “soft float” distribution which is not available anymore on Raspberry Pi web site.

In order to use WComp on Raspberry Pi, you will have to do the following:

  • Download the Debian "soft float" distribution
  • If you are using a Raspberry Pi Rev B with 512MB, you should replace the files bootcode.bin and start.elf after writing the system on SD card in order to be able to boot you system.
  • Upgrade your system:
sudo apt-get update
sudo apt-get upgrade
  • When logged in, install mono environment:
sudo apt-get install mono-complete
  • Unzip SharpWCompContainer where you want, to be able to us it.